Instalasi Script WA Blast

Diposting oleh admin pada 11 September 2021
Requirement Aplikasi:
1. php 7.4 keatas beserta apache dan MySQL
2. NodeJs NPM versi 6 ke atas
3. Gunakan user selain root untuk documentroot
4. Composer
5. Yarn, apabila ada kegagalan instalasi dengan npm
6. pm2, untuk management nodejs
7. Disarankan menggunakan panel yang full support ssh dan bisa customize seperti vestacp atau hestiacp
 
Instalasi:
1. Download file zip dan extract di dalam documentroot
2. Import database blast.sql
3. Install vendor di aplikasi root, di console Linux ketika sudah berada dalam lokasi root ketik composer install
4. Masuk ke folder public dan ketik npm install, apabila gagal bisa dengan ketik yarn install
5. Masuk ke folder bf2, ketik npm install
6. Setting database pada file di dokumentroot/.env
7. Setting database pada file bf2/db_config.js
8. Install pm2
9. Jalankan file bf2/botfy-run.js menggunakan pm2 : pm2 start bf2/botfy-run.js
10. Jalankan file bf2/botfy-restart.js menggunakan pm2 : pm2 start bf2/botfy-restart.js
11. Untuk menggunakan fasilitas chat dan import kontak, ganti isi file botfy.xyz.key dan botfy.xyz.crt sesuai dengan domain yang didapat dari letsncrypt atau vendor lainnya